Follow

Troubleshooting your CorelDRAW, Corel DESIGNER, and Corel PHOTO-PAINT file thumbnails

This article discusses problems with viewing your Corel graphics thumbnails in File Explorer, explains what may be causing these problems, and offers step-by-step troubleshooting instructions.


I just installed the latest version of the suite, and in File Explorer (Windows Explorer), I see only white icons or application icons instead of thumbnail previews for my files. What should I do?

 

Issue with the file association

The problem you are experiencing may be caused by incorrect file association. This issue may occur both when previous versions of the program are installed on the same computer, and when only the latest version of the program is installed.

1. Restart Windows to ensure that all programs are closed and there are no Windows updates pending.

2. Using File Explorer, browse and find the files that are displayed with white icons or product icons.

    The following file types support thumbnails and preview:

    CDR, CDT, DES, FILL, CPT, CSL, PAT

3. Right-click one of the files.

4. In the context menu, click Open with.

5. Select the latest version of the program with which to associate this file type. For example,  choose CorelDRAW for CDR, CDT, FILL, CSL and PAT files; Corel PHOTO-PAINT for CPT files; and Corel DESIGNER (as part of CorelDRAW Technical Suite) for DES files.

6.Enable the following check box:

    • (Windows 7) Always use the selected program to open this kind of file
    • (Windows 8) Use this app for all .cdr files
    •  (Windows 10) Always use this app to open .cdr files

7. Click OK.

Important note! After you select the program and complete steps 6 and 7, the file association becomes permanent because it is entered as a UserChoice in the Microsoft Windows registry. Installing a new version of the program will not automatically associate this file type with the new version. You must repeat the procedure above to change the file association to the new version.

 

If the problem persists, try the following procedure.

1. Launch CorelDRAW.

2. Click Tools menu > Options.

3. In the Options dialog box, click Global > Filters > Associate.

By default, you should have CDR and CSL selected.

4. Enable the check boxes for the file types you want, or disable and then enable the check boxes for the file types you are having problems with.

5. Click OK.

6. Close the application for the changes to take effect.

Note: The same steps apply to Corel PHOTO-PAINT and Corel DESIGNER. The default extension selected for Corel PHOTO-PAINT is CPT. If you have CorelDRAW Technical Suite 2017, the extensions enabled by default for Corel DESIGNER are CGM, DES, DRW, DS4, DSF, DST, MGX.

 

Corel Graphics - Windows Shell Extension may not be installed

This may be the cause for white icons or application icons appearing instead of thumbnails. Corel Graphics - Windows Shell Extension lets you view the contents of your Corel graphics files through thumbnails.

1. Restart Windows to ensure all programs are properly closed and there are no Windows updates pending.

2. Go to the Windows Control Panel, and under Programs, click Uninstall a program.

3. Make sure that Corel Graphics - Windows Shell Extension is included in the list of installed programs.

If it is listed, go to the next section.

If it is not listed, continue with this procedure.

4. Double-click the suite name (for example, CorelDRAW Graphics Suite or CorelDRAW Technical Suite).

5. Enable the Modify option in the wizard that appears, click Next, and then Next again.

6. On the Program features page, click the drop-down box next to Utilities, and enable the Windows Shell Extension check box.
Note: If Corel Graphics - Windows Shell Extension is installed, the corresponding check box will not be displayed.

7. Click Next, and continue with the installation.

8. When the installation is complete, restart Windows to refresh the Windows thumbnail cache.

If the problem persists, proceed to the next section.

 

Corel Graphics - Windows Shell Extension may be corrupted or out of sync with the latest installed version of CorelDRAW Graphics Suite or CorelDRAW Technical Suite.

In some cases, you may introduce a Shell extension (thumbnail) issue when you uninstall the latest shell extension from your computer and repair an older version of the Suite. In this case, the shell extension and the suite applications are no longer in sync (they have different versions).

The best way to resolve this issue is to uninstall the latest version of the Suite and Shell Extension and then reinstall the suite as part of the latest Suite install from Add/Remove programs, choosing Custom installation. This will ensure that the application version and the Shell extension are synchronized (the same version is installed). Follow the procedure below.

1.Restart Windows to ensure all programs are properly closed and there are no Windows updates pending.

2. Open the Windows Control Panel, and under Programs, click Uninstall a program.

3. Double-click the suite name (for example, CorelDRAW Graphics Suite or CorelDRAW Technical Suite).

4. Enable the Remove option.

To completely uninstall the product by removing user files, such as presets, user-created fills, and customized files, enable the Remove user files check box.

5. Click Remove.

6. Next, double click Corel Graphics - Windows Shell Extension in the list of programs, and click Yes.

7. Restart Windows.

8.Reinstall the latest version of the suite, choosing Custom Installation. Make sure to select Windows Shell extension from the Utilities drop-down list box in the Installation wizard, and follow the instructions.

Note: You may have to re-apply any updates (if applicable).

If the problem persists, proceed to the next section.

 

Microsoft Windows Thumbnail cache needs to be refreshed

Using Microsoft Disk Cleanup

Windows keeps a copy of all your picture, video, and document thumbnails so they can be displayed quickly when you open a folder. In some situations, corruptions can occur. Deleting these thumbnail cache files may help. The thumbnail cache will be automatically recreated.

1. Restart Windows.

2. On your Windows search bar, type Disk Cleanup.

(Windows 8.1.3) Enable the Free up disk space by deleting unnecessary files option.

3. In the Disk Cleanup: Drive Selection dialog box, select drive C: or the drive where Windows is installed, and click OK.

4. In the Files to delete list, ensure the Thumbnails check box is enabled. (You can disable other items). Click OK.

5. Click Delete Files (This action resets the thumbnail files in  C:\Users\<username>\AppData\Local\Microsoft\Windows\Explorer\, and may take a while.)

6. Restart Windows.

7. Start CorelDRAW, create a new file, add some objects, and save the file on your desktop.

8. Close CorelDRAW.

9. Verify that the thumbnail is visible.

If you still see a white icon, double-click it. If you are asked how you want to open this file, select CorelDRAW and make sure to enable the check box that lets you always open this file type in this app (namely, CorelDRAW).

 

Microsoft Windows Icon cache needs to be refreshed

  1. Open File Explorer, and click  View > Options.
  2. In the Folder Options dialog box, click View, enable the Show hidden files, folders, and drives option, and click OK.
  3. Go to the C:\Users\%username%\AppData\Local folder, and delete the IconCache.db file, which is hidden by default.
  4. Restart Windows.

 

Older files may not be recognized

If it's an old CorelDRAW file, older than version 6, it may not be recognized as a CorelDRAW file.

 

Sometimes I see thumbnails, and sometimes I see icons in File Explorer

If you are in File Explorer, depending on the operating system and the View option, a thumbnail or an icon may show for a file.

From the View menu, make sure to choose Extra large icons, Large icons, Medium icons, or Small icons. You can also hold down Ctrl and scroll up or down using your mouse and keyboard to resize the thumbnails.

 

I see thumbnails for some recent files but not for all recent files with the same file extension.

Perhaps, a thumbnail was never added to the file, or the thumbnail may be corrupted. Simply, open the file in CorelDRAW and resave the file. This may fix the thumbnail issue.

Another method to try with a newer file is to create a copy of the file and change its extension from .CDR to .ZIP in File Explorer. (Ensure Hide extensions for known file types is unchecked in File View menu > Options > View tab so that you can see the file extension in the file name). Then, open the zip file, and ensure the previews folder exists and that you can preview the PNG files. If you can see the PNG files, then the problem is somewhere else in the file or in Windows. (Don’t forget to rename the file back to CDR if you want to open it in CorelDRAW.)

 

I cannot see thumbnails in Corel CONNECT, but I can see the thumbnails in File Explorer for the same files.

We recommend deleting the CorelSearchCache.db file by following these steps:

1. Open File Explorer, and type %temp% in the Address bar and then press Enter on your keyboard.

This action opens the Temp folder. If the Temp folder does not appear, you can browse to it:  C:\Users\<username>\AppData\Local\Temp\

2. Select CorelSearchCache.db, and press Delete.

CorelSearchCache.db will be regenerated the first time you start and use Corel CONNECT.

Note: The procedure below applies only to local installations. You cannot use it if you have a workstation from an admin image.

1. Launch Corel CONNECT.

2. In the upper-right corner, click the gear icon, and then click Options.

3. Click Clear Thumbnail Cache.

4. Close and restart Corel CONNECT.

This will clear the folder %AppData%\Local\Temp\Connect.ThumbnailCache

and re-cache CONNECT Thumbnails on first-time use.

 

I have one specific CorelDRAW file that does not show a thumbnail.

If the preceding procedure doesn’t help, try the following:

1. Open the problematic file in CorelDRAW.

2. Select all the objects by double-clicking the Pick tool. This action will select all objects on page 1.

3. Copy the selected objects by clicking Edit > Copy or pressing Ctrl+C.

4. Create a second document and paste the content by clicking Edit > Paste or pressing Ctrl+V.

5. Save the new document.

Note: If you have a multipage document, you need to repeat these steps for each page. Check if the thumbnail is being generated.

 

I have a Corel PHOTO-PAINT (CPT) file that does not show a thumbnail.

This CPT file may have been exported from CorelDRAW as CPT. In such cases, a thumbnail is not added to the file. Open the file in Corel PHOTO-PAINT, click File menu > Save as, and then replace the existing image. A thumbnail is added to the file.

 

I have tried all solutions listed above, and I still can’t view thumbnails.

Check your Windows User Profile

1. Close all programs.

2. From your Windows desktop, log off, and then log on as another user to see if that resolves the issue with being unable to view the thumbnails.

3. If the problem persists, try opening the file on another computer with the same version of the application. This step will help determine if the problem is with the file or if the problem exists only on your computer.

If you can open the file on another computer, then the file is not the problem. Try to narrow down the differences between the two user profiles from step 2.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.