Follow

HOW TO: Effectively Use Batch Processing in PaintShop Pro

 


We at Corel understand that creativity does not have to be time consuming. We have incorporated several time saving features, including one-click Noise Removal, an easy to use tilt shift feature and several other tools that can give you the results you need with just a few clicks, so you can spend more time capturing your photos.

In this tutorial, you will learn the techniques to process an image and apply the editing to multiple photos at the same time.

Step 1 – Set up the file

From the Manage tab, navigate your collection and select an image that you would like to start with. Keep in mind that the process you will be applying will come from the edits on this particular image, so choosing an image with almost the same properties as the others will give you better over-all results.

It is also best to write down your planned steps so the batch process will be as optimized as possible.


 Fig 1. Editing images one by one may sound simple enough, unless you are faced with repetitive process and need to process hundreds of images – then batch processing is very useful.


Step 2 (Optional) – Record the Editing Process as a Script

This is an optional step, but if you are planning on using the process in the future, it is wise to record it as a script.

To Start Recording, make sure that the Script Toolbar is enabled. Go to View > Toolbars > Script, to enable it.


Fig 2. The Script toolbar is used to record, play and save scripts.


Step 3 – Start Editing

Click on the Start Script recording. Refer on the steps that you have written down on paper, this would further save you time and optimize the recording of the script.

For the purpose of this tutorial, these would be my steps:

1. Resize the image to 30% as these images will be uploaded to my Flickr account.
2. Add a simple black border using selection and fill.
3. Add my signature




 Fig 3. Before and After applying editing.

After saving the file, Click on the Save Script Recording then give it a name. For easy recall, name it something that is relevant to what it can do.


Fig 4. Script Save window will save the script to the Restricted folder if it uses a File Menu operation (ex. File > Save).


Step 4 – Apply Batch Processing

There are two ways you can apply batch processing on your images. First is by using the script that you have just created. Second is by capturing the steps in the Manage view and then applying it to the selected images. Both have their own pros and cons.

Using the script:

1. Go to File > Batch Process.
2. Click on Browse, then select all the images you want to include in your batch process.
3. Check the “Use Script” check box then select the script you have created.
4. Modify other options as needed.
5. Click Start to start the batch process.


Fig 5. The Batch processing window


Using Capture Editing

1. Go to Manage View
2. Select the image that you have just edited. You will notice that on the corner of the image is a pencil icon. This means that edits from this image can be captured.
3. Click on the Capture editing button.



4. Select the images that you want to batch process.
5. Click on Apply Editing button. The processing window should appear. Click OK to exit.


Fig 6. Batch process applied to multiple images.

Note: You can only capture editing directly after editing a photo. If you have started a new session with Paintshop Pro, capture editing will not work.

 

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.