Follow

Customizing CorelDRAW Graphics Suite to Fit Your Workflow

By Steve Bain

When it comes to the creative freedom to radically change your software's user interface, few applications come close to CorelDRAW Graphics Suite. By changing your CorelDRAW or Corel PHOTO-PAINT workspace, you can go wild with custom toolbars, command menus, and shortcuts to create a look and feel to suit your workflow or your tastes.

Besides the cool factor, there's an invaluable practical side to customizing your workspace. It's surprising how quickly each extra moment you spend adjusting tool settings or sifting through options can add up over the course of a task or project. Organizing and optimizing your workspace can yield an invaluable resource that many of us often lack -- time.


What makes a workspace a workspace?

So, what exactly constitutes a workspace? Essentially, a workspace is a collection of interface settings. It includes the current state and positioning of all dockers, command menus, and toolbars as well as shortcut keys and status bar display. Workspaces also include any customized items you have created such as new menus or custom toolbars.

The workspace files in CorelDRAW Graphics Suite use the XML file format, which means that the files can be easily created, saved, and shared. You can save or share different workspaces for specific designs, layouts, or graphic operations, or create a workspace that emulates other applications. Virtually any interface element can be moved, copied, or deleted, enabling you to personalize your program to suit your own work habits or needs. In this tutorial, we'll explore how to switch between workspaces, customize toolbars and shortcut keys, save your workspace, export your workspace, set document defaults, and restore your application to its original factory settings. That's plenty of ground to cover, so we'd better get started.

 

Switching between workspaces

CorelDRAW comes with several preset workspaces, each of them optimized for a specific type of workflow (for example, illustration or page layout). To switch from one workspace to another, click Window > Workspace, and choose the workspace you want.

 

Customizing toolbars interactively

Instead of choosing a preset workspace, you can create your own custom workspace by customizing any menu or toolbar. You can use the customization features in the Options dialog box, but the interactive method is much more intuitive. All it takes is dragging an item from one menu or toolbar to another.

  • To create a new toolbar, hold down Ctrl + Alt while dragging an item from a toolbar or menu.
  • To copy a button or command, hold down Ctrl + Alt while dragging the item to a different toolbar or menu.
  • To move a button or command, hold down Alt while dragging the item to a new toolbar or menu.
  • To delete a button or command, hold down Alt while dragging the item off the toolbar or menu.


It's important to press and hold the keys before you begin the mouse action.

When you create a new toolbar, it is automatically named New Toolbar 1 by default. To change the toolbar's name, open the Options dialog box (Ctrl + J), click Workspace > Customization > Command Bars to view the Command Bars list, locate your new toolbar, click the toolbar name twice, and type a new name. You can also display or hide toolbars by enabling or disabling the corresponding check boxes.


Toolbars can include elements from various command bars, so you can mix and match elements from any existing toolbar or menu.

You can also add flyouts to your custom toolbars. A flyout is essentially a grouped collection of buttons. Creating new flyouts and copying or moving items from other flyouts requires a little more wrist action.

 

1. Right-click your custom toolbar, and choose Customize > [name of toolbar] > Add New Flyout. A new empty flyout button is added to the toolbar.

2. Open the flyout from which you want to copy a button.

3. Hold down Ctrl + Alt while dragging the button from the source flyout until your mouse pointer is over the target flyout. Before releasing the mouse button, you'll see the target flyout open. After it opens, move your pointer onto it, and then release the mouse button.

 

Customizing shortcut keys

You can access shortcut customization options in the Options dialog box by clicking Workspace > Customization > Commands and clicking the Shortcut Keys tab.

 

Saving your workspace

After you’ve customized your menus and toolbars, you can save your custom workspace.

1. Click Tools > Options (Ctrl + J), and click Workspace to view the workspace options.

2. Click New. In the New Workspace dialog box, type a name for your workspace and an optional description. Click OK to save the workspace and return to the Options dialog box


Your custom workspace is saved and can be accessed from the list. The check mark indicates that it is currently loaded. Click OK to close the dialog box.

Exporting your workspace

There are two ways to preserve your custom CorelDRAW or Corel PHOTO-PAINT workspace -- either by saving your workspace, or by exporting it. The export operation creates a file that you can email, share with colleagues, or copy to other systems.

1. Right-click any toolbar and choose Customize > Workspace > Export from the popup menu.

2. In the Export Workspace dialog box, choose the workspace settings that you would like to include, and click Save.

 

 

3. In the Save As dialog box, enter a name and location for the file, and click Save.

4. In the Export Workspace dialog box, click Close.

 

Setting document defaults

If you're new to the workspace concept, it may help to know what is and isn't stored in a workspace file. For example, your CorelDRAW workspace does not determine document-level settings. Document settings include defaults such as fill and outline properties for graphic and text objects, a variety of general display preferences, as well as page, ruler, grid, guideline, and style options. These settings provide an extra layer of customization if you need it. You can choose which settings applied to your document to save as defaults for other documents in the Options dialog box by choosing the Document options. Enable the check marks next to the settings you wish to save.

After you have selected which document settings to save, you can immediately save all current document settings as defaults for new documents by choosing Tools > Save Settings as Default. Any currently applied document settings will be saved in your default CorelDRAW.cdt template file and automatically applied to each new document file you create.

 

Restoring your workspace to factory defaults

At this point, you may be wondering how you're going to undo what you've done so far. You can return to the Options dialog box anytime and choose a different workspace.

You can also return your workspace to its original factory default state.

1. Close CorelDRAW (or Corel PHOTO-PAINT).

2. Hold the F8 key, and restart the application. Click Yes in the dialog box that appears.

 

 

 

If you've never ventured into the powerful world of customization of CorelDRAW Graphics Suite, this tutorial has exposed you to some intriguing possibilities. It may also help to know that although it applies to CorelDRAW Graphics Suite X7, similar features are available in previous releases.

Steve Bain is an award-winning illustrator and designer, and an author of nearly a dozen books, including CorelDRAW®: The Official Guide.

 

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.