Follow

CorelCAD™ May 2012 update - Release Notes

 

This release updates previous CorelCAD Builds (11.4.209, 11.6.208 and 11.8.1054) to v. 12.4.056.

New features

  • CorelDRAW® (.CDR) and Corel DESIGNER® (.DES) import (Windows® only!)
    Import CorelDRAW and Corel DESIGNER files into CorelCAD on Windows as model space objects with a representation in a layout sheet. This update includes import support for:
    • Multi-page .cdr and .des files
    • CorelDRAW (.cdr) files from version 8 to the current release (X6)
    • Corel DESIGNER (.des) files from version 10 to the current release (X5)
  • PDF Underlay functionality (Insert menu > PDF Underlay...)
    Attach one or more pages of a PDF document to your drawing and control the layer visibility and clipping (masking areas) of the PDF Underlay.
  • Pack & Go command (File menu > Export > Pack and Go...)
    Create a package (ZIP archive or folder) containing the current drawing and its dependent files, such as References, referenced images, referenced PDF files, font files, font mapping files, PrintStyle files, and Print Configuration files.
  • FLATSHOT command (Solids menu > 3D Operations > Make Flat Snapshot)
    Create a flat representation of 3D solid objects, projected to the X-Y plane of the drawing.
  • PASTE@SOURCEPOSITION command (Edit menu > Paste at Source Position)
    Paste copied objects (entities) to their original position, within the original document or in a new or other open document.
  • Enhanced Mac OS® X Lion feature support
    Full screen application mode is now supported in CorelCAD on Mac OS X Lion (10.7).
  • Enhanced STL (Stereolithography) file export (File menu > Export > Export...)
    You can export multiple 3D solid objects to STL, the most commonly used file format for 3D prints (used as processing format in 3D printers).
  • FIELD feature (Insert menu > Field...)
    Create Fields for annotations that are used to dynamically update information, such as modification date, drawing name and author in visible text objects.

Enhancements

  • Layer filters improvements and fixes
  • Rendering features:
    • Accelerated panning in model views and layout sheets
    • Improved sub-entity highlighting
    • Memory (performance) improvements for animated rendering and previews

Other improvements

  • Improved object snap (ESnap) functionality: object tracking and ortho mode enhancements
  • Hebrew, Thai and Arabic text improvements (single line and paragraph text objects)
  • Table tool: various improvements
  • Display grid and snap now match in isometric (top, right, left) orientation
  • Block attributes no longer display or print with gray filled areas
  • Mac OS® X: Application error report improvements
  • User profile ready for update support
    Future CorelCAD versions will be able to maintain custom workspaces and user profiles when being installed as an update to this application version.


Previous version release notes: CorelCAD November 2011 update

This release updates the initial CorelCAD Builds (11.4 and 11.6) to v.11.8.

New features

  • Dimension tools
    • New Smart Dimensioning added
    • Flip dimension arrows functionality added
    • Dimensioning of model space entities in layouts (viewports)
  • Print Configurations (save layout-specific output settings for use across files and projects)
  • ESRI shape (*.SHP) file format support (Open & Save) (new in v11.6.208)
  • Built-in Update Notification (for future updates)
  • Mac OS® X version-specific new features
    • Insert/ Edit VoiceNote
    • Spell Checker
    • Mac OS X 10.7 (Lion) support
  • Windows® version-specific new features
    • 3Dconnexion input device support

Enhancements

  • Entity snapping of model space entities in layout sheets
  • Overall performance improvements for display operations (zoom, pan, render)
  • Mac® startup performance improved
  • Improved and enhanced 3D modeling capabilities
    • Enhancements/ improvements in existing 3D editing tools (i.e. EDITSOLID, EXTRUDE, REVOLVEDMESH, CONE, CYLINDER, TORUS, SPHERE)
    • New 3D editing tools added (LOFT between 3D surfaces; FILLET 3D EDGES)
  • TrueType® Fonts - Printing improvements (much smaller files for texts with TTF fonts; more accurate text printing)
  • Improved and enhanced automation interface (LISP programming enhancements)

Other improvements

  • Printing improvements
  • Memory and performance improvements for 3D display
  • Full Mac OS X 10.7 (Lion) support
  • Display issues in Mac version fixed (missing geometry issues, font issues, general issues)
  • Local language support improvements in Mac version

v12.4 2012-06-14

 

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.