Follow

How do I recover a damaged Quattro® Pro spread sheet?

This document will outline exactly how to repair a damaged Quattro® Pro spread sheet. WARNING: The methods outlined below are not guaranteed to work in all cases. There are instances where a spread sheet will be corrupted beyond Quattro Pro's ability to repair or recover data. It is highly recommended that you backup any existing data before attempting this procedure.


There are a number of ways of repairing a damaged Quattro® Pro spread sheet. This document will attempt to cover most known methods including inserting, combining files, or using the Quattro Pro document repair flags. If Quattro Pro cannot repair your damaged file, then inserting the document into WordPerfect® can sometimes yield positive results. NOTE: The following document has been tested with Quattro Pro versions 9 and above.

Inserting & Combining Documents

Inserting a Quattro Pro file:

  1. Open Quattro Pro into a blank spread sheet.
  2. Go up to the Insert file menu and click on Insert File.


NOTE: If the insert menu option is greyed out, ensure that you are not entering data into a cell. Click on the red X next to the data entry box on your toolbar. Try step 2. again.

  1. On the right hand side of the File Name box click on the file folder icon.
  2. Select the file that you want to insert and click on Open.

If this does not repair the damage to your spread sheet, and Quattro Pro crashes as a result,try combining the file with a new document.

To do this, follow the instructions below: NOTE: Combining files will only work with Quattro Pro versions 10 and up.

  1. Open Quattro pro into a blank spread sheet.
  2. Go up to the Tools menu and select the Data Tools submenu. Click on Combine Files
  3. Click on the file folder icon on the right hand side of the File Name box.
  4. Select the file that you want to combine and click on Open.

If Quattro Pro cashes while combining files, try the steps again accept this time, click on the Cell(s) button within the Combine Files dialog box. Enter a sheet name which you would like to extract such as A: or B: If you know of the sheet name enter that instead.

Using the Quattro Pro repair flags

Quattro Pro comes with repair flags which can be used to strip out various objects types or formulas. Below is a listing of the repair flags including their function:

/R1 - Strips out Objects such as text boxes ,graphic boxes & charts.

/R2 - Does the same as /R1 accept it strips out all formulas in a document and substitutes them with values.

/V - Will attempt to repair a damaged formula or list in Quattro Pro. This function works in Quattro Pro 11 and up *ONLY*.

Before attempting to use the repair functions of Quattro Pro. It will be easier if your corrupted document is on the root directory of your primary hard drive. To place a copy of your file on the root directory, follow the instructions below:

  1. Open Quattro Pro.
  2. Go up to the File menu then click on Open.
  3. Click once on your corrupted Quattro Pro file.
  4. Click on the Edit menu then select Copy.
  5. Click on the down arrow next to the Look In box and click on your primary hard drive. This is usually "C:\" but may be different depending on your system configuration.
  6. Go up to the Edit menu then select Paste.
  7. Close Quattro Pro.

To repair your spread sheet follow the instructions below:


Quattro Pro 9:

  1. Click on Start and go up to Run.
  2. Type the following into the Open box: "C:\Program Files\Corel\WordPerfect Office 2000\Programs\QPW.EXE" /R1 "C:\FileName.qpw" NOTE: Substitute filename.qpw with the name of your damaged spread sheet. Ensure that you type the filename in EXACTLY and include a .QPW extention at the end. If the file your trying to repair is a Quattro Pro

 

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.