Follow

AfterShot Pro 3: Upgrade Eligibility

To purchase the upgrade version of AfterShot Pro 3, you must own a previous licensed version of: Bibble Pro or Lite 5, Corel® AfterShot Pro®, Corel® Paint Shop Pro® Photo X2 or higher, Adobe® Lightroom® or Apple® Aperture®.

Was this article helpful?
1 out of 2 found this helpful
Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.