フォローする

Paint Shop Pro シリーズで手書き文字をスキャンして文字だけを使用するには?

  1. Paint Shop Proで [ファイル] メニューより [開く] をクリックします。
    → [開く] ウィンドウが開きます。

  2. 手書き文字を取り込んだスキャン画像ファイルや素材集などから使用したい画像ファイルをクリックして選択します。

  3. [開く] ボタンをクリックします。
    注記: 以下の操作は TrueColor (24ビット) もしくはグレー スケールの画像に対して有効です。 素材が GIF などの形式である場合は予めカラー モードを変更しておきます。

    カラー モードを変更する手順は以下の通りです。
    TrueColor (24ビット) に変更する場合: [画像] メニューより [増色] - [RGB-8 ビット/チャネル] をクリックします。

    グレー スケールに変更する場合: [画像] メニューより [グレースケール] をクリックします。

  4. [レイヤー] メニューより [新しいマスクレイヤー] -[画像から] をクリックします。
    → [画像からマスクを作成] ウィンドウが開きます。

  5. [作成元画像] として現在開かれているファイル名を指定します。

  6. [マスクの作成元] として [画像全体の明度] を指定します。

  7. [マスクデータを反転する] オプションをオンにします。
    注記: ハッキリくっきりしているような画像の場合はマスクの作成元を [0以外の値] とするとキレイに出来上がります 。

  8. [OK] ボタンをクリックします。
    これでマスクが作成され、白い部分が透過された状態になります。 これで文字の部分だけを抜き出すことができる状態になりました。 マスクを使用することによって色の薄い部分は半透明になりますので、自然な感じで抜き出すことができます。

これでマスクが作成され、白い部分が透過された状態になります。 これで文字の部分だけを抜き出すことができる状態になりました。 マスクを使用することによって色の薄い部分は半透明になりますので、自然な感じで抜き出すことができます。

マスクを使用することによって、文字の色を以下の手順で簡単に変更することもできます。

  1. レイヤー パレット内で上記の手順で作成されたレイヤーをクリックして選択します。
  2. [レイヤー] メニューより [新しいラスタレイヤー] をクリックします。
    → [新しいラスタレイヤー] ウィンドウが開きます。
  3. [OK] ボタンをクリックします。
    → レイヤー パレットで確認すると新しいラスタ レイヤーがマスク レイヤーの上に作られています。 このレイヤーは文字の色を変更するために使用します。
  4. [レイヤー] メニューより [順序] - [背面へ移動] をクリックします。
    → レイヤー パレットで確認すると新しいレイヤーがマスク レイヤーの下に移動されています。
  5. ツール パレットより塗りつぶしツールを選択します。
  6. マテリアルパレットで塗りつぶしに使用する前景色または背景色を選択します。
  7. ツール オプション パレットの [比較モード] ドロップリストで、次のいずれかのオプションを選択します。
    [なし] ― すべてのピクセルを塗りつぶします。
    [RGB値] ― 赤、緑、青の値が一致する隣接したピクセルを塗りつぶします。
    [カラー] ― 色相、彩度の値が一致する隣接したピクセルを塗りつぶします。
    [色相] ― 色相の値が一致する隣接したピクセルを塗りつぶします。
    [明るさ ] ― 明るさの値が一致する隣接したピクセルを塗りつぶします。
    [すべての不透明領域] ― 不透明なピクセルをすべて塗りつぶします。
    [不透明度] ― 不透明度の値が一致する隣接したピクセルを塗りつぶします。
  8. [許容誤差] コントロールに、0 から 200 までの値を入力/設定し、選択したピクセルが、クリックした最初のピクセルと比較して、どのくらいの誤差までを条件に適合すると判断するかを指定します。 
    低い値の設定では、かなり似かよった色のピクセルのみが塗りつぶされます。高い値を設定すると、塗りつぶされるピクセルの数が多くなります。
  9. [ブレンドモード] ドロップダウン リストでオプションを選択し、塗りつぶされたピクセルが下のレイヤーのピクセルと混ぜ合わされる方法を指定します。ブレンド モードはレイヤー ブレンド モードと同じです。
  10. [不透明度] コントロールに値を入力/設定し、塗りつぶしの不透明度を指定します。100% の不透明度では、ペイントがすべてを覆います。1% の不透明度では、ペイントがほとんど透明になります。
  11. 塗りつぶしたい選択範囲や画像にポインタを置いて、前景のプロパティの色でペイントするには左マウス クリックし、背景のプロパティの色でペイントするには右マウス クリックします。

さらに、抜き出した文字を他の画像と合成することもできます。

  1. [編集] メニューより [結合部分をコピー] をクリックします。
  2. 貼り付け先の画像を開き、[編集] メニューより [貼り付け] - [新しいレイヤー]、または [新しいレイヤーとして貼りつけ] をクリックします。
    → コピーした文字が貼り付けられます。
    必要に応じてツール パレットより ピック ツール (Paint Shop Pro 9 以前では変形ツール) を使用して文字の大きさや位置を調整します。
この記事は役に立ちましたか?
0人中0人がこの記事が役に立ったと言っています
他にご質問がございましたら、リクエストを送信してください

0 コメント

ログインしてコメントを残してください。